Back to overview
Downtime
Server unexpectedly shut off
Jun 24 at 03:55pm NZST
Affected services
Utilities
Resolved
Jun 24 at 09:07pm NZST
Server is now back up!
Affected services
Created
Jun 24 at 03:55pm NZST
The server that hosts Utilities is now down. I will get in contact with my hosting service to resolve the issue.
Affected services